Download How to use Elegance 6-3

Survey
yes no Was this document useful for you?
   Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Document related concepts

Single-unit recording wikipedia , lookup

Neuropharmacology wikipedia , lookup

Transcript
NERVOUS SYSTEM RECONSTRUCTION
USING ELEGANCE
May, 2007
Scott W. Emmons [email protected]
David Hall [email protected]
Meng Xu [email protected]
Overview
Elegance is a JAVA-based program that facilitates the tracing
and reconstruction of neurons across serial section images. The
location of a neuron profile in an image is represented by a single
point and neuron reconstructions are non-volumetric stick figures.
Neuron diagrams created by Elegance show the pathway of the
neuron through the tissue or organism and neuron architecture
along with the locations of synapses along each branch. Multiple
neurons can be traced simultaneously.
To reconstruct a neuron, the locations of structures in images,
both neurite profiles and synapses, are entered from the computer
screen with the mouse. Coordinates and associated attributes are
stored in a MYSQL database. Relationships across images are
stored in a Connectivity Table. Data points and connections entered
with the mouse are shown in overlays on top of the images, which
remain inviolate. From the information in the database tables,
Elegance draws neuron diagrams.
2D diagram of a C. elegans sensory neuron
dorsal
anterior
posterior
ventral
Entrance point into the ganglion
~1 µm
section number
Diagrams show locations of synapses and
synaptic partners
Overview of steps in reconstruction: Entering and loading
images, defining objects
•
•
•
•
•
To begin a reconstruction project using Elegance, the user first enters information
about a stack of digitized images (TIFF format). Key information includes section
number and directory location. Section number is used to calculate the z coordinate.
To enter information from images into the database, multiple images are loaded into
RAM. Elegance displays a specified number of images side-by-side on the computer
screen in section number order. The user can scroll through the stack in RAM with
left and right arrows. Data can be entered from one image at a time by selecting it.
Double clicking with the mouse anywhere on a selected image creates an object with
a unique identification number. The object identifier and its associated X, Y, Z
coordinate are entered into an Object Table in the database. (0,0) is at the lower lefthand corner of the image.
There are two object types: neuron and synapse. Double click creates an object of
neuron type. Neuron type objects are shown on the screen as a blue square. They
are used to identify and mark the centers of neuron profiles.
ALT double click creates an object of synapse type. After Alt double click, the
program prompts for the kind of synapse, chemical or gap junction, and waits for the
identities of the pre and post-synaptic neurons to be entered. To enter this
information, while continuing to hold the ALT key, first click on the pre-synaptic
neuron object and then on post-synaptic neuron objects. Post-synaptic neurons can
be of any number, allowing for polyadic synapses. When the ALT key is released, a
red circle appears indicating the location of the synapse object and pre- and postsynaptic objects are listed beside it.
Overview of steps in reconstruction: Connecting neurons
across sections, creating “contins” and neuron diagrams
•
•
•
Neurons are traced out by connecting neuron type objects in adjacent sections. To
connect two objects, in a selected image CTRL click on the first object (it turns
green). Select an adjacent image (by clicking anywhere). CTRL click the second
object. Elegance draws a line across the images connecting the two objects and
enters a record in the Connectivity Table consisting of the two object names.
To reconstruct a neuron, the user asks Elegance to calculate a “contin.” A contin is a
string of connected neuron objects representing a partially or fully reconstructed
neuron. Starting from a user selected neuron object, Elegance queries the
Connectivity Table and collects all the objects joined directly to the chosen object or
indirectly to it via other objects in a continuous chain, moving through the stack in
both directions and along all branches until all ends are found. Elegance assigns a
unique contin number to this chain (or reassigns the previous number to a
recalculated contin). The contin number and a user assignable alternate name (such
as a neuron name) are displayed over lines between connected objects in the contin
on the computer screen.
To obtain a printable diagram of a neuron, the user asks Elegance to first find all the
synapses belonging to a particular contin. Then the user asks Elegance to create a
diagram of the neuron.
The following are a series of screen shots
illustrating the stages of reconstruction
1. Appearance of the Elegance screen upon opening the program.
Elegance allows for entering a username at login. Multiple users can log in
simultaneously and enter data into the database (but they should avoid
simultaneously opening the same images). When data is entered or
modified in the Object Table, username and date/time are recorded in
appropriate fields for every record, so that the person who created or
modified the record can be later determined.
2. To enter information about image files, click Image, Enter. Image
Number is the key field for the Image Table. Directory tells Elegance where
to find the image, Section Number is used to calculate the Z coordinate for
neuron diagrams.
3. To select images to be loaded into RAM, click Image, Find and enter
criteria for a range of images. In the following example, to see all the images
in the PAG series, “P” was entered in the “Image Number” and “Approximately
Matches” box. When the list of images appears, select those desired and
click Load.
4. The 10 images selected are loaded into RAM and 3 are displayed on the
screen. Initially they may be out of order. Click left arrow or right arrow
to automatically order the stack and to scroll through it. The selected
image is shown by the purple bar at the top. Use Zoom and the other
tools at the bottom of the screen to adjust magnification and other
aspects of the selected image. These changes are applied to overlays
and do not affect the original image. To see different areas, use the
arrow as a “hand” tool by holding down the left button while moving the
mouse (there must be no selected object in the image, see below). The
X and Y coordinates of the mouse arrow are given at the lower left-hand
corner. Translations, as well as zoom and other operations, may be
applied to all the images in RAM simultaneously by clicking Image and
checking “Lock Images.”
The images shown here are scans of paper prints from a C.
elegans reconstruction project. The prints were previously marked with
pen and colored ink.
5. To create a neuron object, double click on a selected image. The object
number appears next to the object, and object number and coordinates are
entered into the Object Table. Initially, neuron objects are shown as blue
squares. After the user has marked all the synapses of a particular profile,
this may be indicated by converting the square to a circle (hold m and click
the object to “mark” it; hold “u” and click an object to “unmark” it and
convert it back to a square). Thus the progress of the reconstruction can
be recorded and visualized on the screen.
Create a synapse object by holding ALT and double clicking at the location
of the synapse. When prompted, select the type of synapse, chemical or
gap junction, then, while continuing to hold ALT, click in order the
presynaptic object and one or more post-synaptic objects. When ALT is
released, this information appears next to the synapse object.
Objects, both neuron and synapse types, can be selected and moved. To
select an object, click it. It turns amber. To unselect an object, click
anywhere away from the object. Delete key deletes a selected object
along with its record in the data table. Delete connections to other objects
before deleting an object (see below). To move a selected object, hold the
mouse button and drag. The new coordinates are updated to the
database.
All operations on objects are updated in the database and refreshed on the
screen automatically.
Here we see that object 4930 (red 45) is presynaptic (the presynaptic
density is in red 45, which contains synaptic vesicles) at two dyadic
chemical synapses, one with 1628 (red 68) and 4931 (red 67), and one
with 4366 (violet 29) and 4931 (red 67). 4366 (violet 29) is presynaptic at
a dyadic chemical synapse with 4929 (red 84) and 4931 red (67).
6. To connect corresponding profiles in adjacent sections, select the
first object by CTRL click (it turns green), then select an adjacent
image and CTRL click the second object. Elegance connects the
objects with a line and enters a record in the Connectivity Table. To
delete a connection, follow the same procedure with two connected
objects. Elegance responds that these objects are already
connected and asks for instructions. Click delete.
7. Calculating a “contin.” Before Elegance can make a neuron diagram,
it must collect all connected objects that are part of the neuron from the
connectivity table. A chain of connected objects is called a contin. There
are two ways to calculate a contin: within Elegance, click an object while
holding down “c”, a calculation will be initiated from this object; or, outside
Elegance, run the application Calculate Contin and enter an object
number where the calculation should start. If adding newly connected
objects to a preexisting contin, start the calculation from a previously
included object to preserve the original contin number.
As Elegance calculates a contin, it identifies objects that are either
branchpoints or ends and assigns a segment number to all the objects in
the segment lying between them. Pairs of branchpoint and endpoint
objects and the assigned segment number they define are entered in a
Segment Endpoint Table, which is used in drawing neuron diagrams.
After a calculation, select View, Refresh. Elegance displays contin
number, alternate contin name, and segment number over the lines
connecting objects on the screen. Here we see that red 45 is contin 211,
the neuron HOB, and lies on segment 1; red 67 is contin 201, the neuron
EF1, segment 3; and violet 27 is contin 760, the neuron R3BL, segment
8.
8. To calculate a neuron diagram, first calculate the synapse list for
that neuron by running the Calculate Synapses application. Elegance
places these in a temporary table. Then select the type of diagram
desired. 2D-Y displays the Z coordinate (section number) along the X
axis and the Y value along the Y axis. 2D-X displays the Z coordinate
along the X axis and the X value along the Y axis. For a series in
which sectioning was perpendicular to the anteroposterior axis with
numbers increasing moving from anterior to posterior, Y represents the
dorsoventral axis (numbers increasing ventral to dorsal), and X
represents the left/right axis (numbers increasing left to right), which is
the case in the examples shown here. 2D-Y is a view of the neuron
from the left side, with left/right deviations projected onto the plane of
the image, while 2D-X is a view from the top, with dorsoventral
deviations projected onto the plane of the image. Versions of these
two programs that display the stick figure diagram without synapses
are also available. Elegance makes a neuron diagram by connecting
endpoints and branchpoints with straight lines. The object number and
section number of these key points are displayed. Both axes are
scaled to fit the JAVA screen image created. To print the image, select
Print Screen and paste the image into another program (like
Powerpoint or Microsoft Office Picture Manager).
The following example is contin 760, R3BL, 2D-Y diagram.
2D diagram of a C. elegans sensory neuron
dorsal
anterior
posterior
ventral
Entrance point into the ganglion
~1 µm
section number
Vertical arrows indicate chemical synapses and their polarity, vertical
lines indicate gap junctions. For each synapse, a line running parallel to
the neuron branch indicates the sections over which that synapse runs
continuously. In the region shown here, R3BL is pre-synaptic to EF1 in
several places, and postsynaptic to HOA, HOB, R6BR, and several other
neurons.
A region of R3BL showing the synapses.
List of programs
•
•
•
•
•
•
•
Elegance
Calculate Contin
Calculate Synapses
2D-X
2D-Y
2D-X without synapses
2D-Y without synapses
Nervous system
wiring using Elegance
Scott Emmons
David Hall
Programming: Meng Xu
Initial version of software: Metahelix Life Sciences Ltd.
Electron micrographs: N. Thomson, D. Albertson
Previous Support: NIH, Albert Einstein College of Medicine
Current support: Mathers
Foundation, Mt. Kisco, NY
WE INVITE SOFTWARE USERS!