Download DCN2: Network Design and Analysis Using Switches

Survey
yes no Was this document useful for you?
   Thank you for your participation!

* Your assessment is very important for improving the workof artificial intelligence, which forms the content of this project

Document related concepts

Piggybacking (Internet access) wikipedia , lookup

Airborne Networking wikipedia , lookup

Recursive InterNetwork Architecture (RINA) wikipedia , lookup

Zero-configuration networking wikipedia , lookup

Nonblocking minimal spanning switch wikipedia , lookup

Cracking of wireless networks wikipedia , lookup

Spanning Tree Protocol wikipedia , lookup

Virtual LAN wikipedia , lookup

Transcript
FACULTY OF ENGINEERING
ECE2056 DATA COMMUNICATIONS AND NETWORKING
LAB EXPERIMENT
DCN2: Network Design and Analysis Using Switches
TRIMESTER 3 SESSION 2015/2016
YL Foo, 2016 Apr
Page 1
Pre-Requisite: For the tasks given in this experiment, the students must have completed them in
the simulator. Otherwise, it would be a waste of time running this experiment, and it may even
damage the equipments used.
For the following tasks, remember to capture the screen shots of your works, and put them in your
report.
Prepare the Lab Report using the Report Template. Print the report on two-sided papers.
Learning Outcome: Construct a basic local area network that consists of multiple routers and
switches.
Introduction
The following experiment uses two routers and four switches. Routing is performed at Layer 3,
whereas switching is performed at Layer 2. But some switches can perform function similar to
routing. We call this Layer 3 Switching. Since a switch is a Layer 2 device, it does not understand
IP address (of Layer 3). We can construct virtual local area networks (VLANs) on the switches, and
IP addresses can be assigned to the VLAN interfaces (VLANIFs).
Scenario
Suppose you manage a network that consists of four users. Each of them belongs to different
VLANs. Users belong to the same VLAN can communicate with each other, but not with users
from different VLANs. In the following task, we bridge their communication by setting up a Layer
3 link between two switches.
1. Basic Operations
Identify a console cable.
Identify the routers (AR2200 or AR2220).
Identify the switches (S5700 and S3700).
Connect a PC to a router or a switch using a console cable.
Run a terminal emulation program such as Putty on the PC to create a connection.
Select either COM3 or COM4 port. Set the followings: 9600 bits per second, 8 data bits, no parity,
1 stop bit, and no flow control.
Power on the routers and switches.
When the startup process is complete, a command prompt is shown. You are now in User View
environment. If you are prompted with the question: Do you want to stop Auto Configurations?
Choose ‘y’ for ‘yes’.
Run the reset saved-configuration command to clear all previous configurations.
Note: Question mark (?) is a wildcard, and the Tab is used as a shortcut to enter commands.
You will be prompted with the question: The action will delete the saved configuration in the device.
The configuration will be erased to reconfigure. Continue? Answer: Choose ‘y’ for ‘yes’.
Run the system-view command to access the System View. Most of the following tasks can only be
completed in System View.
Try to change the font size to 12. Change the Background Color to white, Font Color to black (save
a lot of printer ink when you print!).
You can change the device name using sysname command.
For your lab group, choose a unique ID, preferably one of the students’ ID.
Change the name of the first router AR1 to the group ID by typing "sysname group ID AR1".
Name the second router AR2 as "your group ID AR2".
YL Foo, 2016 Apr
Page 2
Name the first switch LSW1 as "your group ID LSW1".
Name the second switch LSW2 as "your group ID LSW2".
Name the third switch LSW3 as "your group ID LSW3".
Name the fourth switch LSW4 as "your group ID LSW4".
Topology
Connect the routers and switches following the topology below.
2. Configure VLANs on LSW1 and LSW2
LSW1 belongs to VLANs 3, 4, and 5. Create these VLANs in batches at LSW1 by running the
command vlan batch 3 to 5.
LSW2 belongs to VLANs 5, 6, and 7. Create these VLANs in batches at LSW1 by running the
command vlan batch 5 to 7.
Add GE 0/0/3 of LSW1 and LSW2 to VLAN 5 by running the following commands:
int g 0/0/3
port link-type access
port default vlan 5
quit
At LSW1, add GE 0/0/1 to VLAN 3:
int g 0/0/1
port link-type access
port default vlan 3
quit
At LSW1, add GE 0/0/2 to VLAN 4:
int g 0/0/2
port link-type access
port default vlan 4
quit
You can double-check the configurations by running the command dis vlan. Print screen and show
the screenshot. The screenshot must be CLEAR enough to read.
YL Foo, 2016 Apr
Page 3
At LSW2, add GE 0/0/1 to VLAN 7, and add GE 0/0/2 to VLAN 6.
You can double-check the configurations by running the command dis vlan. Print screen and show
the screenshot. The screenshot must be CLEAR enough to read.
3. Configure gateway IP addresses for the VLANs of LSW1 and LSW2
LSW1 provides gateway services for VLANs 3 to 5, whereas LSW2 provides gateway services for
VLANs 5 to 7.
Configure IP addresses for VLANIFs 3 to 5 on LSW1:
int vlanif 3
ip add 10.0.3.1 24
quit
int vlanif 4
ip add 10.0.4.1 24
quit
int vlanif 5
ip add 10.0.5.1 24
quit
You can double-check the configurations by running the command dis int vlanif.
In similar manner, at LSW2, assign IP addresses
10.0.5.2/24 to VLANIF 5
10.0.6.1/24 to VLANIF 6
10.0.7.1/24 to VLANIF 7
You can double-check the configurations by running the command dis int vlanif.
4. Configure IP addresses and default routes for LSW3 and LSW4
By default, all ports in a switch belong to VLAN 1 (running the command dis vlan will reveal this).
At LSW3, we configure an IP address for VLANIF 1. The network identifier (netid) of the IP
address is the same as that of VLAN 3 at LSW1. By doing so, LSW3 becomes part of the VLAN 3.
The commands are:
int vlanif 1
ip add 10.0.3.33 24 (the address can be 10.0.3.X, X = 2 to 254)
quit
ip route-static 0.0.0.0 0 10.0.3.1 (creating a default route to 10.0.3.1 of LSW1)
At LSW4, we configure an IP address for VLANIF 1. The network identifier (netid) of the IP
address is the same as that of VLAN 7 at LSW2. By doing so, LSW4 becomes part of the VLAN 7.
The commands are:
int vlanif 1
ip add 10.0.7.44 24 (the address can be 10.0.7.X, X = 2 to 254)
quit
ip route-static 0.0.0.0 0 10.0.7.1 (creating a default route to 10.0.7.1 of LSW2)
5. Configure IP addresses and default routes for AR1 and AR2
YL Foo, 2016 Apr
Page 4
At AR1, we assign an IP address to GE 0/0/2. The network identifier (netid) of the IP address is the
same as that of VLAN 4 at LSW1. By doing so, AR1 becomes part of the VLAN 4.
The commands are:
int g 0/0/2
ip add 10.0.4.11 24 (the address can be 10.0.4.X, X = 2 to 254)
quit
ip route-static 0.0.0.0 0 10.0.4.1 (creating a default route to 10.0.4.1 of LSW1)
At AR2, we assign an IP address to GE 0/0/2. The network identifier (netid) of the IP address is the
same as that of VLAN 6 at LSW2. By doing so, AR2 becomes part of the VLAN 6.
The commands are:
int g 0/0/2
ip add 10.0.6.33 24 (the address can be 10.0.6.X, X = 2 to 254)
quit
ip route-static 0.0.0.0 0 10.0.6.1 (creating a default route to 10.0.6.1 of LSW2)
6. Test the connectivity
VLANs 3 and 4 are connected via LSW1. Thus LSW3 can communicate with AR1.
But VLANs 3 and 4 are not connected to VLANs 6 and 7. Thus LSW3 cannot communicate with
AR2 and LSW4.
Proofs:
At LSW3, ping 10.0.4.11 (of AR1). Print screen and show the screenshot. You should get a positive
reply.
At LSW3, ping 10.0.6.33 (of AR2). Print screen and show the screenshot. You should get a
negative reply.
At LSW3, ping 10.0.7.44 (of LSW4). Print screen and show the screenshot. You should get a
negative reply.
Describe/Explain the results.
In similar manner,
At AR1, ping 10.0.3.33 (of LSW3). You should get a positive reply.
At AR1, ping 10.0.6.33 (of AR2). You should get a negative reply.
At AR1, ping 10.0.7.44 (of LSW4). You should get a negative reply.
Describe/Explain the results.
VLANs 6 and 7 are connected via LSW2. Thus LSW4 can communicate with AR2.
But VLANs 3 and 4 are not connected to VLANs 6 and 7. Thus LSW4 cannot communicate with
AR1 and LSW3.
Proofs:
At LSW4, ping 10.0.6.33 (of AR2). Print screen and show the screenshot. You should get a positive
reply.
At LSW4, ping 10.0.4.11 (of AR1). Print screen and show the screenshot. You should get a
negative reply.
YL Foo, 2016 Apr
Page 5
At LSW4, ping 10.0.3.33 (of LSW3). Print screen and show the screenshot. You should get a
negative reply.
Describe/Explain the results.
In similar manner,
At AR2, ping 10.0.7.44 (of LSW4). You should get a positive reply.
At AR2, ping 10.0.4.11 (of AR1). You should get a negative reply.
At AR2, ping 10.0.3.33 (of LSW3). You should get a negative reply.
Describe/Explain the results.
7. Troubleshooting
We have seen that AR1 and AR2 fail to communicate with each other. Run the tracert command to
troubleshoot the fault.
At AR1, tracert 10.0.6.33. Describe/Explain the result.
Check at gateway LSW1.
At LSW1, dis ip rou to display the routing table. Print screen and show the screenshot.
Does LSW1 have a route to the network segment 10.0.6.0? Describe/Explain the result.
8. Solution: Implement a routing protocol on both LSW1 and LSW2
For example, enable OSPF on LSW1 and LSW2.
At both LSW1 and LSW2, run the following commands:
ospf 1
area 0
network 10.0.0.0 0.255.255.255
After they have exchanged routes, view their respective routing tables.
Show the routing tables of LSW1 and LSW2. Describe/Explain the results.
Now test the connectivity again. You should now get positive replies from the followings:
At LSW3, ping 10.0.6.33 (of AR2).
At LSW3, ping 10.0.7.44 (of LSW4).
At AR1, ping 10.0.3.33 (of LSW3).
At AR1, ping 10.0.6.33 (of AR2).
At AR1, ping 10.0.7.44 (of LSW4).
At LSW4, ping 10.0.4.11 (of AR1).
At LSW4, ping 10.0.3.33 (of LSW3).
At AR2, ping 10.0.7.44 (of LSW4).
At AR2, ping 10.0.4.11 (of AR1).
At AR2, ping 10.0.3.33 (of LSW3).
Prove them by showing their respective screenshots. Describe/Explain the results.
YL Foo, 2016 Apr
Page 6