Download users.nik.uni

Survey
yes no Was this document useful for you?
   Thank you for your participation!

* Your assessment is very important for improving the workof artificial intelligence, which forms the content of this project

Document related concepts
no text concepts found
Transcript
Virtual LAN
Számítógép hálózatok gyakorlata
ÓBUDAI EGYETEM
2011 TAVASZI FÉLÉV
9. LABORGYAKORLAT
PRÉM DÁNIEL
Virtual Local Area Network
• VLAN ≠ WLAN
• Virtual LAN (logically related network)
broadcast domain inside the switch
• VLANs are stored in the VTP (VLAN trunking protocol)
databases
• Configurable parameters of VLANs:
name, type, state
• Some VLANs have a distinguished task, others can be
used as arbitrarily (e.g.: 1 = management vlan)
• Cisco VLAN ranges
– normal range: 1-1000 (configurable from 2)
– extended range: 1025-4096
Virtual Local Area Network
• Machines in the same VLAN see each other as
if they were in a normal LAN.
• Machines in separate VLANs don’t see traffic of
the other VLAN (not even when they are
connected to neighbouring ports on the same
switch – 2nd layer)
• Separate VLANs can only communicate if there
is routing between them (same as in normal
LANs) – 3rd layer
• VLANs need configurating on switches and
routers as well
VLAN Trunking
• Makes it possible to multiplex the traffic of
more than one logical networks on one
cable
• VLANID is used to separate the traffic
• Connection types:
– Access:
– Trunk:
1 VLAN traffic
Multiple VLANs batched
(dot1Q -> IEEE 802.1q standard)
VLAN configuration in routers
•
•
•
•
•
•
•
•
Router(config)# interface FastEthernet X/Y
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface FastEthernet X/Y.Z
Router(config-subif)# encapsulation dot1Q [VLAN]
Router(config-subif)# ip address [IP addr.] [subnet mask]
Router(config-subif)# no shutdown
Router(config-subif)# exit
• Where:
– X,Y:
– Z:
– [VLAN]:
Interface ID
Sub interface ID (usually the VLANID)
The VLAN ID
VLAN configuration on Swiches
•
•
•
•
•
Switch> enable
Switch# configure terminal
Switch(config)# vlan [VLAN]
Switch(config-vlan)# name [VLAN_NAME]
Switch(config-vlan)# exit
• Where:
– [VLAN]:
is the VLAN ID
– [VLAN_NAME] is the friendly name of the VLAN
VLAN configuration on Swiches
• //one interface
Switch(config)# interface FastEthernet X/Y
• //interface range
Switch(config)# interface range FastEthernet X/Y-Z
• Switch(config-if-range)# switchport access vlan [VLAN]
• Switch(config-if-range)# no shutdown
• Switch(config-if-range)# exit
• Where:
– X,Y:
ID of the first interface
– Z:
ID of the last interface
– [VLAN]: The VLAN ID
VLAN configuration on Swiches
• //one interface
Switch(config)# interface FastEthernet X/Y
• // interface range
Switch(config)# interface range FastEthernet X/Y-Z
•
•
•
•
Switch(config-if-range)# switchport mode trunk
Switch(config-if-range)# switchport trunk allowed vlan add [VLAN 1]
Switch(config-if-range)# switchport trunk allowed vlan add [VLAN 2]
Switch(config-if-range)# switchport trunk allowed vlan add [VLAN N]
• Where:
– X,Y:
ID of the first interface
– Z:ID of the last interface
– [VLAN]:
The VLAN ID
Related documents